Procedure to follow to export a model from Maya to HALCA

 

1.       Install the plug-in’s for Maya and 3ds Max: FBX Importer/Exporter 2010 available on Autodesk’s web site: http://usa.autodesk.com/adsk/servlet/index?siteID=123112&id=10775855

I used Maya 2008 and 3dsMax 2008, but this plug-in also works with Maya 8.5, Maya 2009, and it’s supposed to work with 3ds Max 2009 too.

2.       Open the scene in Maya

3.       Change all the textures in the model to JPEG format (you can do this either in Maya or later on with 3ds Max).

4.       “File” → “Export All”, select the path, choose a name, select the format .fbx, “Export”,

 

 

Make sure that the FBX version is FBX2010 for 3ds Max and “Export”.

 

5.       Store the file cal3d.dll in the main 3ds Max folder, and the file cal3d_max9_exporter.dle in the folder stdplugs (inside the previous one)

6.       Import the .fbx file previously created in 3ds Max (again, the version of the importer has to be 2010)

7.       If you’re working with a whole body avatar with a mesh and a skeleton, follow the tutorial on how to export a model from 3ds Max to HALCA, and here finishes the tutorial for you. If it doesn’t work, see the possible problems found in the end of this tutorial.

If not,

7.1.    Press ‘H’, select the root geometry, “OK”.

7.2.    “Edit” → “Edit Named Selection Sets”, click on the button with brackets, edit the selection set’s name to ‘Mesh’.

7.3.    Create a ‘Bone’, press ‘H’, select all the geometry (not the bone), “Accept”

7.4.    Go to the “Modifiers” tag, select ‘Skin’ from the display list, and add the bone you just created.

7.5.    Press ‘H’, select only the bone, go to “Edit Named Selection Sets”, press the button with brackets and name it ‘Skeleton’

8.       Look for the file ‘export_cal3D.ms’ and drag it to the 3ds Max window

9.       Set the options like the ones in the picture below

 

 

10.   Export!

 

In case there are blendshapes too, the export above should have been done with the neutral pose of the character. After that, you must set each blendshape to 1.0 one by one, leaving the other blendshapes to 0.0, and exporting the geometry:

 

“File” → Export, save wherever but with the format .cmf, look for the skeleton exported for the geometry, Next, Next…

 

-          Problem with materials:

 

Version 2010 of the FBX is still beta, so it has some errors that must be solved in future versions.

If the 3dsMax crashes when you’re trying to export it all to halca, make sure that none of the materials is lambert, if so, you can create your own texture in jpeg imitating the color in the lambert material and add it to the part of the model that has that material.

Don’t forget to add the new texture to the others when you’re trying to view the model in the XVR!

If you choose the fast option which is changing the type of material, the only was I make it work is by changing it into Blinn when I was in 3dsMax.

 

-          Problem with meshes and bones when you’re trying to export from Maya / import to 3ds Max:

 

Sometimes you find that some models have some entities called “Helpers” when you’re in 3dsMax. These entities add extra difficulties to the exportation process and they don’t seem to be necessary at all. When you’re trying to export to HALCA, you may find that those entities should have been assigned a material when they cannot be assigned any; moreover, you can also find that not selecting the entities, the export to HALCA crashes everytime you try it.

What I did to solve these problems was going back to Maya and deal with it there.

When you have the model already loaded in Maya, go to “Window” ”Hypergraph: Hierarchy”. You’ll see all the subparts of the model there; the future helpers are there too. Click on every subpart of the geometry hanging from any helper and holding the middle botton of the mouse drag this submesh out of that subhierarchy, you’ll see this submesh at the same level as the beginning of all the hierarchies in this window (if you did it correctly). Do this with all the submeshes untill the only hierarchy remaining are the helpers themselves; erase them and close. Now, when you go to 3ds Max you’ll see all the submeshes separately; then, after pressing ‘H’ and before naming all the geometry as ‘Mesh’, select all those subparts, and then name them. The following steps are exactly those in the other tutorial.